{"action":"Upgrade pdfmake to 0.3.6 or later.","affected":[{"fixed":"0.3.6","introduced":"0.3.0-beta.2"}],"component":"pdfmake","cve_ids":["CVE-2026-26801"],"ecosystem":"npm","epss":0.00511,"exploited":false,"fixed_versions":["0.3.6"],"ghsa_id":"GHSA-wp52-r2fp-4vmr","id":"tcs_01M5KGFH1NBAH7S512690ZT7R7","modified_at":"2026-03-19T16:49:29.331008Z","published_at":"2026-03-10T21:32:15Z","references":["https://osv.dev/vulnerability/GHSA-wp52-r2fp-4vmr","https://nvd.nist.gov/vuln/detail/CVE-2026-26801","https://github.com/bpampuch/pdfmake/pull/2920","https://github.com/bpampuch/pdfmake","https://github.com/bpampuch/pdfmake/blob/master/src/URLResolver.js","https://github.com/bpampuch/pdfmake/releases/tag/0.3.6","https://mariopepe.github.io/cve-2026-26801-pdfmake-ssrf"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"GHSA-wp52-r2fp-4vmr","url":"https://osv.dev/vulnerability/GHSA-wp52-r2fp-4vmr"}],"summary":"pdfmake is vulnerable to server-side request forgery (SSRF)"}