{"action":"Upgrade numpy to 1.19.0 or later.","affected":[{"fixed":"1.19.0","introduced":"0"}],"component":"numpy","cve_ids":["CVE-2021-41496"],"ecosystem":"PyPI","epss":0.00396,"exploited":false,"fixed_versions":["1.19.0"],"ghsa_id":"GHSA-f7c7-j99h-c22f","id":"tcs_01M5KGFNFG130HNZ3J28DZAE3C","modified_at":"2023-11-08T04:06:59.274139Z","published_at":"2021-12-17T20:15:00Z","references":["https://osv.dev/vulnerability/PYSEC-2021-857","https://github.com/numpy/numpy/issues/19000","https://github.com/advisories/GHSA-f7c7-j99h-c22f"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2021-857","url":"https://osv.dev/vulnerability/PYSEC-2021-857"}],"summary":"Buffer overflow in the array_from_pyobj function of fortranobject.c in NumPy < 1.19, which allows attackers to conduct a Denial of Service attacks by carefully constructing an array with negative valu"}