{"action":"Upgrade zope to 4.6 or later.","affected":[{"fixed":"4.6","introduced":"0"},{"fixed":"5.2","introduced":"5.0"}],"component":"zope","cve_ids":["CVE-2021-32633"],"ecosystem":"PyPI","epss":0.01858,"exploited":false,"fixed_versions":["4.6","5.2"],"ghsa_id":"GHSA-5pr9-v234-jw36","id":"tcs_01M5KGFSJZTEH56S9AEHE45CYT","modified_at":"2026-07-09T16:56:33.295188851Z","published_at":"2021-05-21T14:15:00Z","references":["https://osv.dev/vulnerability/PYSEC-2021-88","https://github.com/zopefoundation/Zope/commit/1f8456bf1f908ea46012537d52bd7e752a532c91","https://github.com/zopefoundation/Zope/security/advisories/GHSA-5pr9-v234-jw36","http://www.openwall.com/lists/oss-security/2021/05/21/1","http://www.openwall.com/lists/oss-security/2021/05/22/1","https://github.com/advisories/GHSA-962m-m8jw-8wrr"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2021-88","url":"https://osv.dev/vulnerability/PYSEC-2021-88"}],"summary":"Zope is an open-source web application server. In Zope versions prior to 4.6 and 5.2, users can access untrusted modules indirectly through Python modules that are available for direct use. By default"}