{"action":"Upgrade tensorflow-gpu to 2.5.3 or later.","affected":[{"fixed":"2.5.3","introduced":"0"},{"fixed":"2.6.3","introduced":"2.6.0"}],"component":"tensorflow-gpu","cve_ids":["CVE-2022-21726"],"ecosystem":"PyPI","epss":0.00825,"exploited":false,"fixed_versions":["2.5.3","2.6.3"],"ghsa_id":"GHSA-23hm-7w47-xw72","id":"tcs_01M5KGFXX33MPJCBDC5GQN29RY","modified_at":"2026-07-13T16:43:33.650835472Z","published_at":"2022-02-03T11:15:00Z","references":["https://osv.dev/vulnerability/PYSEC-2022-105","https://github.com/tensorflow/tensorflow/security/advisories/GHSA-23hm-7w47-xw72","https://github.com/tensorflow/tensorflow/commit/23968a8bf65b009120c43b5ebcceaf52dbc9e943","https://github.com/tensorflow/tensorflow/blob/5100e359aef5c8021f2e71c7b986420b85ce7b3d/tensorflow/core/kernels/dequantize_op.cc#L92-L153"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2022-105","url":"https://osv.dev/vulnerability/PYSEC-2022-105"}],"summary":"Tensorflow is an Open Source Machine Learning Framework. The implementation of `Dequantize` does not fully validate the value of `axis` and can result in heap OOB accesses. The `axis` argument can be"}