{"action":"Upgrade tensorflow-gpu to 2.5.3 or later.","affected":[{"fixed":"2.5.3","introduced":"0"},{"fixed":"2.6.3","introduced":"2.6.0"}],"component":"tensorflow-gpu","cve_ids":["CVE-2022-21727"],"ecosystem":"PyPI","epss":0.00665,"exploited":false,"fixed_versions":["2.5.3","2.6.3"],"ghsa_id":"GHSA-c6fh-56w7-fvjw","id":"tcs_01M5KGFY2G9AX3YDD1HF6MNMEZ","modified_at":"2026-07-13T16:42:48.784678647Z","published_at":"2022-02-03T11:15:00Z","references":["https://osv.dev/vulnerability/PYSEC-2022-106","https://github.com/tensorflow/tensorflow/security/advisories/GHSA-c6fh-56w7-fvjw","https://github.com/tensorflow/tensorflow/commit/b64638ec5ccaa77b7c1eb90958e3d85ce381f91b","https://github.com/tensorflow/tensorflow/blob/5100e359aef5c8021f2e71c7b986420b85ce7b3d/tensorflow/core/ops/array_ops.cc#L3001-L3034"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2022-106","url":"https://osv.dev/vulnerability/PYSEC-2022-106"}],"summary":"Tensorflow is an Open Source Machine Learning Framework. The implementation of shape inference for `Dequantize` is vulnerable to an integer overflow weakness. The `axis` argument can be `-1` (the defa"}