{"action":"Upgrade tensorflow-gpu to 2.5.3 or later.","affected":[{"fixed":"2.5.3","introduced":"0"},{"fixed":"2.6.3","introduced":"2.6.0"}],"component":"tensorflow-gpu","cve_ids":["CVE-2022-21730"],"ecosystem":"PyPI","epss":0.00822,"exploited":false,"fixed_versions":["2.5.3","2.6.3"],"ghsa_id":"GHSA-vjg4-v33c-ggc4","id":"tcs_01M5KGFYHTFNV25E2V81YXSPV8","modified_at":"2026-07-13T16:42:45.302271402Z","published_at":"2022-02-03T11:15:00Z","references":["https://osv.dev/vulnerability/PYSEC-2022-109","https://github.com/tensorflow/tensorflow/security/advisories/GHSA-vjg4-v33c-ggc4","https://github.com/tensorflow/tensorflow/commit/002408c3696b173863228223d535f9de72a101a9","https://github.com/tensorflow/tensorflow/blob/5100e359aef5c8021f2e71c7b986420b85ce7b3d/tensorflow/core/kernels/fractional_avg_pool_op.cc#L209-L360"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2022-109","url":"https://osv.dev/vulnerability/PYSEC-2022-109"}],"summary":"Tensorflow is an Open Source Machine Learning Framework. The implementation of `FractionalAvgPoolGrad` does not consider cases where the input tensors are invalid allowing an attacker to read from out"}