{"action":"Upgrade tensorflow-gpu to 2.5.3 or later.","affected":[{"fixed":"2.5.3","introduced":"0"},{"fixed":"2.6.3","introduced":"2.6.0"}],"component":"tensorflow-gpu","cve_ids":["CVE-2022-21733"],"ecosystem":"PyPI","epss":0.00828,"exploited":false,"fixed_versions":["2.5.3","2.6.3"],"ghsa_id":"GHSA-98j8-c9q4-r38g","id":"tcs_01M5KGFZE0BPDNM4SND4HTE6TN","modified_at":"2026-07-13T16:43:47.097179750Z","published_at":"2022-02-03T12:15:00Z","references":["https://osv.dev/vulnerability/PYSEC-2022-112","https://github.com/tensorflow/tensorflow/blob/5100e359aef5c8021f2e71c7b986420b85ce7b3d/tensorflow/core/kernels/string_ngrams_op.cc#L29-L161","https://github.com/tensorflow/tensorflow/commit/f68fdab93fb7f4ddb4eb438c8fe052753c9413e8","https://github.com/tensorflow/tensorflow/security/advisories/GHSA-98j8-c9q4-r38g"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2022-112","url":"https://osv.dev/vulnerability/PYSEC-2022-112"}],"summary":"Tensorflow is an Open Source Machine Learning Framework. The implementation of `StringNGrams` can be used to trigger a denial of service attack by causing an out of memory condition after an integer o"}