{"action":"Upgrade tensorflow-gpu to 2.5.3 or later.","affected":[{"fixed":"2.5.3","introduced":"0"},{"fixed":"2.6.3","introduced":"2.6.0"}],"component":"tensorflow-gpu","cve_ids":["CVE-2022-21734"],"ecosystem":"PyPI","epss":0.00789,"exploited":false,"fixed_versions":["2.5.3","2.6.3"],"ghsa_id":"GHSA-gcvh-66ff-4mwm","id":"tcs_01M5KGFZM3V40Z9A91S94M2NE1","modified_at":"2026-07-13T16:42:35.041724802Z","published_at":"2022-02-03T13:15:00Z","references":["https://osv.dev/vulnerability/PYSEC-2022-113","https://github.com/tensorflow/tensorflow/security/advisories/GHSA-gcvh-66ff-4mwm","https://github.com/tensorflow/tensorflow/commit/f57315566d7094f322b784947093406c2aea0d7d","https://github.com/tensorflow/tensorflow/blob/5100e359aef5c8021f2e71c7b986420b85ce7b3d/tensorflow/core/kernels/map_stage_op.cc#L519-L550"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2022-113","url":"https://osv.dev/vulnerability/PYSEC-2022-113"}],"summary":"Tensorflow is an Open Source Machine Learning Framework. The implementation of `MapStage` is vulnerable a `CHECK`-fail if the key tensor is not a scalar. The fix will be included in TensorFlow 2.8.0."}