{"action":"Upgrade mqtt-packet to 3.5.1 or later.","affected":[{"fixed":"3.5.1","introduced":"0"},{"fixed":"4.1.3","introduced":"4.0.0"},{"fixed":"5.6.1","introduced":"5.0.0"},{"fixed":"6.1.2","introduced":"6.0.0"}],"component":"mqtt-packet","cve_ids":["CVE-2019-5432"],"ecosystem":"npm","epss":0.01777,"exploited":false,"fixed_versions":["3.5.1","4.1.3","5.6.1","6.1.2"],"ghsa_id":"GHSA-wv67-9jq7-8r69","id":"tcs_01M5KGG0C8FG15HD76N3CX403D","modified_at":"2023-11-08T04:01:36.103305Z","published_at":"2019-05-14T04:02:45Z","references":["https://osv.dev/vulnerability/GHSA-wv67-9jq7-8r69","https://nvd.nist.gov/vuln/detail/CVE-2019-5432","https://hackerone.com/reports/541354"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"GHSA-wv67-9jq7-8r69","url":"https://osv.dev/vulnerability/GHSA-wv67-9jq7-8r69"}],"summary":"Improper Input Validation and Buffer Over-read in mqtt-packet"}