{"action":"Upgrade tensorflow-gpu to 2.5.3 or later.","affected":[{"fixed":"2.5.3","introduced":"0"},{"fixed":"2.6.3","introduced":"2.6.0"}],"component":"tensorflow-gpu","cve_ids":["CVE-2022-23558"],"ecosystem":"PyPI","epss":0.00818,"exploited":false,"fixed_versions":["2.5.3","2.6.3"],"ghsa_id":"GHSA-9gwq-6cwj-47h3","id":"tcs_01M5KGG16C32VBZ7354EC6ACBE","modified_at":"2026-07-13T16:42:29.063162691Z","published_at":"2022-02-04T23:15:00Z","references":["https://osv.dev/vulnerability/PYSEC-2022-122","https://github.com/tensorflow/tensorflow/commit/a1e1511dde36b3f8aa27a6ec630838e7ea40e091","https://github.com/tensorflow/tensorflow/blob/ca6f96b62ad84207fbec580404eaa7dd7403a550/tensorflow/lite/c/common.c#L24-L33","https://github.com/tensorflow/tensorflow/blob/ca6f96b62ad84207fbec580404eaa7dd7403a550/tensorflow/lite/c/common.c#L53-L60","https://github.com/tensorflow/tensorflow/security/advisories/GHSA-9gwq-6cwj-47h3"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2022-122","url":"https://osv.dev/vulnerability/PYSEC-2022-122"}],"summary":"Tensorflow is an Open Source Machine Learning Framework. An attacker can craft a TFLite model that would cause an integer overflow in `TfLiteIntArrayCreate`. The `TfLiteIntArrayGetSizeInBytes` returns"}