{"action":"Upgrade tensorflow-gpu to 2.5.3 or later.","affected":[{"fixed":"2.5.3","introduced":"0"},{"fixed":"2.6.3","introduced":"2.6.0"}],"component":"tensorflow-gpu","cve_ids":["CVE-2022-23567"],"ecosystem":"PyPI","epss":0.01106,"exploited":false,"fixed_versions":["2.5.3","2.6.3"],"ghsa_id":"GHSA-rrx2-r989-2c43","id":"tcs_01M5KGG33NMFAZAP0WPFRVZENS","modified_at":"2026-07-13T16:42:34.027549666Z","published_at":"2022-02-03T12:15:00Z","references":["https://osv.dev/vulnerability/PYSEC-2022-131","https://github.com/tensorflow/tensorflow/security/advisories/GHSA-rrx2-r989-2c43","https://github.com/tensorflow/tensorflow/blob/master/tensorflow/security/advisory/tfsa-2021-198.md","https://github.com/tensorflow/tensorflow/commit/e952a89b7026b98fe8cbe626514a93ed68b7c510","https://github.com/tensorflow/tensorflow/commit/1b54cadd19391b60b6fcccd8d076426f7221d5e8","https://github.com/tensorflow/tensorflow/blob/5100e359aef5c8021f2e71c7b986420b85ce7b3d/tensorflow/core/kernels/sparse_dense_binary_op_shared.cc"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2022-131","url":"https://osv.dev/vulnerability/PYSEC-2022-131"}],"summary":"Tensorflow is an Open Source Machine Learning Framework. The implementations of `Sparse*Cwise*` ops are vulnerable to integer overflows. These can be used to trigger large allocations (so, OOM based d"}