{"action":"Upgrade tensorflow-gpu to 2.5.3 or later.","affected":[{"fixed":"2.5.3","introduced":"0"},{"fixed":"2.6.3","introduced":"2.6.0"}],"component":"tensorflow-gpu","cve_ids":["CVE-2022-23576"],"ecosystem":"PyPI","epss":0.00783,"exploited":false,"fixed_versions":["2.5.3","2.6.3"],"ghsa_id":"GHSA-wm93-f238-7v37","id":"tcs_01M5KGG4SEKGCTTBGSDYXM19CX","modified_at":"2026-07-13T16:43:39.673455519Z","published_at":"2022-02-04T23:15:00Z","references":["https://osv.dev/vulnerability/PYSEC-2022-140","https://github.com/tensorflow/tensorflow/commit/b9bd6cfd1c50e6807846af9a86f9b83cafc9c8ae","https://github.com/tensorflow/tensorflow/blob/a1320ec1eac186da1d03f033109191f715b2b130/tensorflow/core/grappler/costs/op_level_cost_estimator.cc#L1598-L1617","https://github.com/tensorflow/tensorflow/security/advisories/GHSA-wm93-f238-7v37"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2022-140","url":"https://osv.dev/vulnerability/PYSEC-2022-140"}],"summary":"Tensorflow is an Open Source Machine Learning Framework. The implementation of `OpLevelCostEstimator::CalculateOutputSize` is vulnerable to an integer overflow if an attacker can create an operation w"}