{"action":"Upgrade tensorflow-gpu to 2.5.3 or later.","affected":[{"fixed":"2.5.3","introduced":"0"},{"fixed":"2.6.3","introduced":"2.6.0"}],"component":"tensorflow-gpu","cve_ids":["CVE-2022-23581"],"ecosystem":"PyPI","epss":0.0116,"exploited":false,"fixed_versions":["2.5.3","2.6.3"],"ghsa_id":"GHSA-fq86-3f29-px2c","id":"tcs_01M5KGG5JP3Q9HH818EYPBS8RQ","modified_at":"2026-07-13T16:43:51.818165778Z","published_at":"2022-02-04T23:15:00Z","references":["https://osv.dev/vulnerability/PYSEC-2022-145","https://github.com/tensorflow/tensorflow/security/advisories/GHSA-fq86-3f29-px2c","https://github.com/tensorflow/tensorflow/commit/1fb27733f943295d874417630edd3b38b34ce082","https://github.com/tensorflow/tensorflow/commit/240655511cd3e701155f944a972db71b6c0b1bb6","https://github.com/tensorflow/tensorflow/commit/ebc1a2ffe5a7573d905e99bd0ee3568ee07c12c1","https://github.com/tensorflow/tensorflow/blob/a1320ec1eac186da1d03f033109191f715b2b130/tensorflow/core/grappler/optimizers/constant_folding.cc#L1687-L1742"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2022-145","url":"https://osv.dev/vulnerability/PYSEC-2022-145"}],"summary":"Tensorflow is an Open Source Machine Learning Framework. The Grappler optimizer in TensorFlow can be used to cause a denial of service by altering a `SavedModel` such that `IsSimplifiableReshape` woul"}