{"action":"Upgrade tensorflow-gpu to 2.5.3 or later.","affected":[{"fixed":"2.5.3","introduced":"0"},{"fixed":"2.6.3","introduced":"2.6.0"}],"component":"tensorflow-gpu","cve_ids":["CVE-2022-23588"],"ecosystem":"PyPI","epss":0.00872,"exploited":false,"fixed_versions":["2.5.3","2.6.3"],"ghsa_id":"GHSA-fx5c-h9f6-rv7c","id":"tcs_01M5KGG6W3C3N675HATKQGFAHD","modified_at":"2026-07-13T16:43:28.010585964Z","published_at":"2022-02-04T23:15:00Z","references":["https://osv.dev/vulnerability/PYSEC-2022-152","https://github.com/tensorflow/tensorflow/blob/a1320ec1eac186da1d03f033109191f715b2b130/tensorflow/core/grappler/optimizers/constant_folding.cc#L1328-L1402","https://github.com/tensorflow/tensorflow/security/advisories/GHSA-fx5c-h9f6-rv7c","https://github.com/tensorflow/tensorflow/commit/6b5adc0877de832b2a7c189532dbbbc64622eeb6","https://github.com/tensorflow/tensorflow/blob/a1320ec1eac186da1d03f033109191f715b2b130/tensorflow/core/framework/tensor.cc#L733-L781"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2022-152","url":"https://osv.dev/vulnerability/PYSEC-2022-152"}],"summary":"Tensorflow is an Open Source Machine Learning Framework. A malicious user can cause a denial of service by altering a `SavedModel` such that Grappler optimizer would attempt to build a tensor using a"}