{"action":"Upgrade tensorflow-gpu to 2.8.0 or later.","affected":[{"fixed":"2.8.0","introduced":"2.7.0"}],"component":"tensorflow-gpu","cve_ids":["CVE-2022-23593"],"ecosystem":"PyPI","epss":0.0087,"exploited":false,"fixed_versions":["2.8.0"],"ghsa_id":"GHSA-gwcx-jrx4-92w2","id":"tcs_01M5KGG7N022CZ8GTGKTQ8TVK4","modified_at":"2026-07-13T16:43:08.094895293Z","published_at":"2022-02-04T23:15:00Z","references":["https://osv.dev/vulnerability/PYSEC-2022-157","https://github.com/tensorflow/tensorflow/blob/274df9b02330b790aa8de1cee164b70f72b9b244/tensorflow/compiler/mlir/tfrt/jit/transforms/tf_cpurt_symbolic_shape_optimization.cc#L149-L205","https://github.com/tensorflow/tensorflow/security/advisories/GHSA-gwcx-jrx4-92w2","https://github.com/tensorflow/tensorflow/commit/35f0fabb4c178253a964d7aabdbb15c6a398b69a"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2022-157","url":"https://osv.dev/vulnerability/PYSEC-2022-157"}],"summary":"Tensorflow is an Open Source Machine Learning Framework. The `simplifyBroadcast` function in the MLIR-TFRT infrastructure in TensorFlow is vulnerable to a segfault (hence, denial of service), if calle"}