{"action":"Upgrade scrapy to 2.6.1 or later.","affected":[{"fixed":"2.6.1","introduced":"0"}],"component":"scrapy","cve_ids":["CVE-2022-0577"],"ecosystem":"PyPI","epss":0.01228,"exploited":false,"fixed_versions":["2.6.1"],"ghsa_id":"GHSA-cjvr-mfj7-j4j8","id":"tcs_01M5KGG7ZFDP0XEGTBXRZ6QAPV","modified_at":"2025-10-09T08:23:09.449118Z","published_at":"2022-03-02T04:15:00Z","references":["https://osv.dev/vulnerability/PYSEC-2022-159","https://github.com/scrapy/scrapy/commit/8ce01b3b76d4634f55067d6cfdf632ec70ba304a","https://huntr.dev/bounties/3da527b1-2348-4f69-9e88-2e11a96ac585","https://github.com/advisories/GHSA-cjvr-mfj7-j4j8"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2022-159","url":"https://osv.dev/vulnerability/PYSEC-2022-159"}],"summary":"Exposure of Sensitive Information to an Unauthorized Actor in GitHub repository scrapy/scrapy prior to 2.6.1."}