{"action":"Upgrade ansible to 2.9.27 or later.","affected":[{"fixed":"2.9.27","introduced":"0"}],"component":"ansible","cve_ids":["CVE-2021-3620"],"ecosystem":"PyPI","epss":0.0039,"exploited":false,"fixed_versions":["2.9.27"],"ghsa_id":"GHSA-4r65-35qq-ch8j","id":"tcs_01M5KGG8Z433EBBWVN99MAYV2K","modified_at":"2026-02-22T22:48:40.899797Z","published_at":"2022-03-03T19:15:00Z","references":["https://osv.dev/vulnerability/PYSEC-2022-164","https://github.com/ansible/ansible/commit/fe28767970c8ec62aabe493c46b53a5de1e5fac0","https://github.com/ansible/ansible/blob/stable-2.9/changelogs/CHANGELOG-v2.9.rst#security-fixes","https://bugzilla.redhat.com/show_bug.cgi?id=1975767","https://github.com/advisories/GHSA-4r65-35qq-ch8j"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2022-164","url":"https://osv.dev/vulnerability/PYSEC-2022-164"}],"summary":"A flaw was found in Ansible Engine's ansible-connection module, where sensitive information such as the Ansible user credentials is disclosed by default in the traceback error message. The highest thr"}