{"action":"Upgrade guake to 3.8.5 or later.","affected":[{"fixed":"3.8.5","introduced":"0"}],"component":"guake","cve_ids":["CVE-2021-23556"],"ecosystem":"PyPI","epss":0.0113,"exploited":false,"fixed_versions":["3.8.5"],"ghsa_id":"GHSA-7x48-7466-3g33","id":"tcs_01M5KGG94JFV6TQ5FSQMJ4615F","modified_at":"2023-11-08T04:05:11.387134Z","published_at":"2022-03-17T12:15:00Z","references":["https://osv.dev/vulnerability/PYSEC-2022-165","https://github.com/Guake/guake/pull/2017/commits/e3d671120bfe7ba28f50e256cc5e8a629781b888","https://github.com/Guake/guake/pull/2017","https://github.com/Guake/guake/releases","https://snyk.io/vuln/SNYK-PYTHON-GUAKE-2386334","https://github.com/Guake/guake/issues/1796","https://github.com/advisories/GHSA-7x48-7466-3g33"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2022-165","url":"https://osv.dev/vulnerability/PYSEC-2022-165"}],"summary":"The package guake before 3.8.5 are vulnerable to Exposed Dangerous Method or Function due to the exposure of execute_command and execute_command_by_uuid methods via the d-bus interface, which makes it"}