{"action":"Upgrade waitress to 2.1.1 or later.","affected":[{"fixed":"2.1.1","introduced":"0"}],"component":"waitress","cve_ids":["CVE-2022-24761"],"ecosystem":"PyPI","epss":0.0178,"exploited":false,"fixed_versions":["2.1.1"],"ghsa_id":"GHSA-4f7p-27jc-3c36","id":"tcs_01M5KGGA08FWDC2MEZB5A7K9J9","modified_at":"2023-11-08T04:08:35.551138Z","published_at":"2022-03-17T13:15:00Z","references":["https://osv.dev/vulnerability/PYSEC-2022-169","https://github.com/Pylons/waitress/commit/9e0b8c801e4d505c2ffc91b891af4ba48af715e0","https://github.com/Pylons/waitress/security/advisories/GHSA-4f7p-27jc-3c36","https://github.com/Pylons/waitress/releases/tag/v2.1.1"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2022-169","url":"https://osv.dev/vulnerability/PYSEC-2022-169"}],"summary":"Waitress is a Web Server Gateway Interface server for Python 2 and 3. When using Waitress versions 2.1.0 and prior behind a proxy that does not properly validate the incoming HTTP request matches the"}