{"action":"Upgrade mitmproxy to 8.0.0 or later.","affected":[{"fixed":"8.0.0","introduced":"0"}],"component":"mitmproxy","cve_ids":["CVE-2022-24766"],"ecosystem":"PyPI","epss":0.01633,"exploited":false,"fixed_versions":["8.0.0"],"ghsa_id":"GHSA-gcx2-gvj7-pxv3","id":"tcs_01M5KGGA9YH2PMVE7CJ52QEMD4","modified_at":"2023-11-08T04:08:35.674152Z","published_at":"2022-03-21T19:15:00Z","references":["https://osv.dev/vulnerability/PYSEC-2022-170","https://mitmproxy.org/posts/releases/mitmproxy8/","https://github.com/mitmproxy/mitmproxy/security/advisories/GHSA-gcx2-gvj7-pxv3","https://github.com/mitmproxy/mitmproxy/commit/b06fb6d157087d526bd02e7aadbe37c56865c71b"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2022-170","url":"https://osv.dev/vulnerability/PYSEC-2022-170"}],"summary":"mitmproxy is an interactive, SSL/TLS-capable intercepting proxy. In mitmproxy 7.0.4 and below, a malicious client or server is able to perform HTTP request smuggling attacks through mitmproxy. This me"}