{"action":"Upgrade django to 2.2.28 or later.","affected":[{"fixed":"2.2.28","introduced":"2.2"},{"fixed":"3.2.13","introduced":"3.2"},{"fixed":"4.0.4","introduced":"4.0"}],"component":"django","cve_ids":["CVE-2022-28347"],"ecosystem":"PyPI","epss":0.02943,"exploited":false,"fixed_versions":["4.0.4","3.2.13","2.2.28"],"ghsa_id":"GHSA-w24h-v9qh-8gxj","id":"tcs_01M5KGGE80GAYPXNCP00MN97BR","modified_at":"2023-12-06T01:02:11.666037Z","published_at":"2022-04-12T05:15:00Z","references":["https://osv.dev/vulnerability/PYSEC-2022-191","http://www.openwall.com/lists/oss-security/2022/04/11/1","https://docs.djangoproject.com/en/4.0/releases/security/","https://www.djangoproject.com/weblog/2022/apr/11/security-releases/","https://groups.google.com/forum/#!forum/django-announce","https://github.com/advisories/GHSA-w24h-v9qh-8gxj"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2022-191","url":"https://osv.dev/vulnerability/PYSEC-2022-191"}],"summary":"A SQL injection issue was discovered in QuerySet.explain() in Django 2.2 before 2.2.28, 3.2 before 3.2.13, and 4.0 before 4.0.4. This occurs by passing a crafted dictionary (with dictionary expansion)"}