{"action":"Upgrade twisted to 22.4.0 or later.","affected":[{"fixed":"22.4.0","introduced":"0"}],"component":"twisted","cve_ids":["CVE-2022-24801"],"ecosystem":"PyPI","epss":0.028,"exploited":false,"fixed_versions":["22.4.0"],"ghsa_id":"GHSA-c2jg-hw38-jrqq","id":"tcs_01M5KGGEVADZD2Z6K9J7E8R9YW","modified_at":"2023-11-08T04:08:37.020748Z","published_at":"2022-04-04T18:15:00Z","references":["https://osv.dev/vulnerability/PYSEC-2022-195","https://github.com/twisted/twisted/commit/592217e951363d60e9cd99c5bbfd23d4615043ac","https://github.com/twisted/twisted/releases/tag/twisted-22.4.0rc1","https://github.com/twisted/twisted/security/advisories/GHSA-c2jg-hw38-jrqq","https://lists.debian.org/debian-lts-announce/2022/05/msg00003.html"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2022-195","url":"https://osv.dev/vulnerability/PYSEC-2022-195"}],"summary":"Twisted is an event-based framework for internet applications, supporting Python 3.6+. Prior to version 22.4.0rc1, the Twisted Web HTTP 1.1 server, located in the `twisted.web.http` module, parsed sev"}