{"action":"Upgrade vyper to 0.3.2 or later.","affected":[{"fixed":"0.3.2","introduced":"0"}],"component":"vyper","cve_ids":["CVE-2022-24788"],"ecosystem":"PyPI","epss":0.00986,"exploited":false,"fixed_versions":["0.3.2"],"ghsa_id":"GHSA-4mrx-6fxm-8jpg","id":"tcs_01M5KGGF5FXTKD1HFTD4Z1N3CE","modified_at":"2023-11-08T04:08:36.532748Z","published_at":"2022-04-13T19:15:00Z","references":["https://osv.dev/vulnerability/PYSEC-2022-197","https://github.com/vyperlang/vyper/commit/049dbdc647b2ce838fae7c188e6bb09cf16e470b","https://github.com/vyperlang/vyper/security/advisories/GHSA-4mrx-6fxm-8jpg"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2022-197","url":"https://osv.dev/vulnerability/PYSEC-2022-197"}],"summary":"Vyper is a pythonic Smart Contract Language for the ethereum virtual machine. Versions of vyper prior to 0.3.2 suffer from a potential buffer overrun. Importing a function from a JSON interface which"}