{"action":"Upgrade vyper to 0.3.2 or later.","affected":[{"fixed":"0.3.2","introduced":"0"}],"component":"vyper","cve_ids":["CVE-2022-24845"],"ecosystem":"PyPI","epss":0.01426,"exploited":false,"fixed_versions":["0.3.2"],"ghsa_id":"GHSA-j2x6-9323-fp7h","id":"tcs_01M5KGGF9J6AQYB7H4PENFFD8P","modified_at":"2023-11-08T04:08:38.494818Z","published_at":"2022-04-13T22:15:00Z","references":["https://osv.dev/vulnerability/PYSEC-2022-198","https://github.com/vyperlang/vyper/security/advisories/GHSA-j2x6-9323-fp7h","https://github.com/vyperlang/vyper/commit/049dbdc647b2ce838fae7c188e6bb09cf16e470b"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2022-198","url":"https://osv.dev/vulnerability/PYSEC-2022-198"}],"summary":"Vyper is a pythonic Smart Contract Language for the ethereum virtual machine. In affected versions, the return of `<iface>.returns_int128()` is not validated to fall within the bounds of `int128`. Thi"}