{"action":"Upgrade octoprint to 1.8.0 or later.","affected":[{"fixed":"1.8.0","introduced":"0"}],"component":"octoprint","cve_ids":["CVE-2022-1430"],"ecosystem":"PyPI","epss":0.01362,"exploited":false,"fixed_versions":["1.8.0"],"ghsa_id":"GHSA-x7r7-wmj8-vv5g","id":"tcs_01M5KGGFTMXFJETGTAHWNSDTEJ","modified_at":"2023-11-08T04:07:48.625524Z","published_at":"2022-05-18T14:15:00Z","references":["https://osv.dev/vulnerability/PYSEC-2022-200","https://github.com/octoprint/octoprint/commit/8087528e4a7ddd15c7d95ff662deb5ef7de90045","https://huntr.dev/bounties/0cd30d71-1e32-4a0b-b4c3-faaa1907b541","https://github.com/advisories/GHSA-x7r7-wmj8-vv5g"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2022-200","url":"https://osv.dev/vulnerability/PYSEC-2022-200"}],"summary":"Cross-site Scripting (XSS) - DOM in GitHub repository octoprint/octoprint prior to 1.8.0."}