{"action":"Upgrade waitress to 2.1.2 or later.","affected":[{"fixed":"2.1.2","introduced":"2.1.0"}],"component":"waitress","cve_ids":["CVE-2022-31015"],"ecosystem":"PyPI","epss":0.01498,"exploited":false,"fixed_versions":["2.1.2"],"ghsa_id":"GHSA-f5x9-8jwc-25rw","id":"tcs_01M5KGGGW158TA7CASGPD9V4TB","modified_at":"2023-11-08T04:09:22.536443Z","published_at":"2022-05-31T23:15:00Z","references":["https://osv.dev/vulnerability/PYSEC-2022-205","https://github.com/Pylons/waitress/pull/377","https://github.com/Pylons/waitress/issues/374","https://github.com/Pylons/waitress/security/advisories/GHSA-f5x9-8jwc-25rw","https://github.com/Pylons/waitress/commit/4f6789b035610e0552738cdc4b35ca809a592d48"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2022-205","url":"https://osv.dev/vulnerability/PYSEC-2022-205"}],"summary":"Waitress is a Web Server Gateway Interface server for Python 2 and 3. Waitress versions 2.1.0 and 2.1.1 may terminate early due to a thread closing a socket while the main thread is about to call sele"}