{"action":"Upgrade cryptoasset-data-downloader to 1.0.2 or later.","affected":[{"fixed":"1.0.2","introduced":"1.0.0"}],"component":"cryptoasset-data-downloader","cve_ids":["CVE-2022-32998"],"ecosystem":"PyPI","epss":0.02,"exploited":false,"fixed_versions":["1.0.2"],"id":"tcs_01M5KGGK0NBGHMDW26DYT2QCSJ","modified_at":"2023-11-08T04:09:38.435859Z","published_at":"2022-06-24T21:15:00Z","references":["https://osv.dev/vulnerability/PYSEC-2022-217","https://pypi.org/project/cryptoasset-data-downloader/","https://github.com/serhatci/cryptocurrency-historical-data-downloader/issues/8","http://pypi.doubanio.com/simple/request"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2022-217","url":"https://osv.dev/vulnerability/PYSEC-2022-217"}],"summary":"The cryptoasset-data-downloader package in PyPI v1.0.0 to v1.0.1 was discovered to contain a code execution backdoor via the request package. This vulnerability allows attackers to access sensitive us"}