{"action":"Upgrade pyesasky to 1.4.3 or later.","affected":[{"fixed":"1.4.3","introduced":"1.2.0"}],"component":"pyesasky","cve_ids":["CVE-2022-30885"],"ecosystem":"PyPI","epss":0.02141,"exploited":false,"fixed_versions":["1.4.3"],"id":"tcs_01M5KGGKX19ZDN27FGG5J9G3BZ","modified_at":"2023-11-08T04:09:20.276157Z","published_at":"2022-06-24T21:15:00Z","references":["https://osv.dev/vulnerability/PYSEC-2022-220","https://github.com/esdc-esac-esa-int/pyesasky/issues/39","http://pypi.doubanio.com/simple/request","https://pypi.org/project/pyesasky/"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2022-220","url":"https://osv.dev/vulnerability/PYSEC-2022-220"}],"summary":"** Reserved ** The pyesasky for python, as distributed on PyPI, included a code-execution backdoor inserted by a third party. The current version, without this backdoor, is 1.2.0-1.4.2."}