{"action":"Upgrade swagger-typescript-api to 13.12.2 or later.","affected":[{"fixed":"13.12.2","introduced":"0"}],"component":"swagger-typescript-api","cve_ids":["CVE-2026-54663"],"ecosystem":"npm","epss":0.00222,"exploited":false,"fixed_versions":["13.12.2"],"ghsa_id":"GHSA-x36r-4347-pm5x","id":"tcs_01M5KGGM42QXXQJNH9ZHY7QZ1C","modified_at":"2026-07-29T14:56:42.732314Z","published_at":"2026-07-29T14:28:58Z","references":["https://osv.dev/vulnerability/GHSA-x36r-4347-pm5x","https://github.com/acacode/swagger-typescript-api/security/advisories/GHSA-x36r-4347-pm5x","https://github.com/acacode/swagger-typescript-api/pull/1779","https://github.com/acacode/swagger-typescript-api/commit/306d59acb8ffbb00f953f807b97234b21f51d9de","https://github.com/acacode/swagger-typescript-api","https://github.com/acacode/swagger-typescript-api/releases/tag/v13.12.2"],"severity":{"label":"medium","score":6.1},"sources":[{"source":"osv","source_id":"GHSA-x36r-4347-pm5x","url":"https://osv.dev/vulnerability/GHSA-x36r-4347-pm5x"}],"summary":"swagger-typescript-api vulnerable to Server-Side Request Forgery via spec `$ref`"}