{"action":"Upgrade whoogle-search to 0.7.2 or later.","affected":[{"fixed":"0.7.2","introduced":"0"}],"component":"whoogle-search","cve_ids":["CVE-2022-25303"],"ecosystem":"PyPI","epss":0.00969,"exploited":false,"fixed_versions":["0.7.2"],"ghsa_id":"GHSA-mxvc-fwgx-j778","id":"tcs_01M5KGGMSRPW926PH895BH880Q","modified_at":"2023-11-08T04:08:45.680545Z","published_at":"2022-07-12T15:15:00Z","references":["https://osv.dev/vulnerability/PYSEC-2022-226","https://github.com/benbusby/whoogle-search/blob/6d362ca5c7a00d2f691a2512461c5dfbfc01cbb3/app/routes.py%23L448","https://snyk.io/vuln/SNYK-PYTHON-WHOOGLESEARCH-2803306","https://github.com/benbusby/whoogle-search/commit/abc30d7da3b5c67be7ce84d4699f327442d44606","https://github.com/advisories/GHSA-mxvc-fwgx-j778"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2022-226","url":"https://osv.dev/vulnerability/PYSEC-2022-226"}],"summary":"The package whoogle-search before 0.7.2 are vulnerable to Cross-site Scripting (XSS) via the query string parameter q. In the case where it does not contain the http string, it is used to build the er"}