{"action":"Upgrade nvflare to 2.1.2 or later.","affected":[{"fixed":"2.1.2","introduced":"0"}],"component":"nvflare","cve_ids":["CVE-2022-31605"],"ecosystem":"PyPI","epss":0.02129,"exploited":false,"fixed_versions":["2.1.2"],"ghsa_id":"GHSA-hrf3-622q-8366","id":"tcs_01M5KGGNX9W1Z5EEKMKPZ1H5Y1","modified_at":"2023-11-08T04:09:31.225389Z","published_at":"2022-07-01T18:15:00Z","references":["https://osv.dev/vulnerability/PYSEC-2022-232","https://github.com/NVIDIA/NVFlare/security/advisories/GHSA-hrf3-622q-8366"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2022-232","url":"https://osv.dev/vulnerability/PYSEC-2022-232"}],"summary":"NVFLARE, versions prior to 2.1.2, contains a vulnerability in its utils module, where YAML files are loaded via yaml.load() instead of yaml.safe_load(). The deserialization of Untrusted Data, may allo"}