{"action":"Upgrade poetry to 1.1.9 or later.","affected":[{"fixed":"1.1.9","introduced":"0"}],"component":"poetry","cve_ids":["CVE-2022-26184"],"ecosystem":"PyPI","epss":0.0185,"exploited":false,"fixed_versions":["1.1.9"],"ghsa_id":"GHSA-xr2c-5w89-63pv","id":"tcs_01M5KGGP5ZYPJ8RT82KYR2AJGA","modified_at":"2023-11-08T04:08:53.492117Z","published_at":"2022-03-21T22:15:00Z","references":["https://osv.dev/vulnerability/PYSEC-2022-234","https://github.com/python-poetry/poetry/releases/tag/1.1.9","https://github.com/python-poetry/poetry-core/pull/205/commits/fa9cb6f358ae840885c700f954317f34838caba7","https://github.com/advisories/GHSA-xr2c-5w89-63pv"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2022-234","url":"https://osv.dev/vulnerability/PYSEC-2022-234"}],"summary":"Poetry v1.1.9 and below was discovered to contain an untrusted search path which causes the application to behave in unexpected ways when users execute Poetry commands in a directory containing malici"}