{"action":"Upgrade requirejs to 2.3.7 or later.","affected":[{"fixed":"2.3.7","introduced":"0"}],"component":"requirejs","cve_ids":["CVE-2024-38999"],"ecosystem":"npm","epss":0.00844,"exploited":false,"fixed_versions":["2.3.7"],"ghsa_id":"GHSA-x3m3-4wpv-5vgc","id":"tcs_01M5KGGQ434PFFT2NKK1K71F4S","modified_at":"2026-09-10T03:50:16.891512392Z","published_at":"2024-07-01T15:32:19Z","references":["https://osv.dev/vulnerability/GHSA-x3m3-4wpv-5vgc","https://nvd.nist.gov/vuln/detail/CVE-2024-38999","https://github.com/requirejs/r.js/issues/1015","https://github.com/requirejs/requirejs/issues/1854","https://github.com/requirejs/requirejs/pull/1856/commits/ebd7a2ff71473542fa132d0d15c10fb4ed1539e1","https://gist.github.com/mestrtee/9acae342285bd2998fa09ebcb1e6d30a","https://github.com/requirejs/r.js","https://security.snyk.io/vuln/SNYK-JS-REQUIREJS-5416713"],"severity":{"label":"critical","score":10},"sources":[{"source":"osv","source_id":"GHSA-x3m3-4wpv-5vgc","url":"https://osv.dev/vulnerability/GHSA-x3m3-4wpv-5vgc"}],"summary":"jrburke requirejs vulnerable to prototype pollution"}