{"action":"Upgrade untangle to 1.2.1 or later.","affected":[{"fixed":"1.2.1","introduced":"0"}],"component":"untangle","cve_ids":["CVE-2022-33977"],"ecosystem":"PyPI","epss":0.01806,"exploited":false,"fixed_versions":["1.2.1"],"ghsa_id":"GHSA-7xr3-6ggc-wc9p","id":"tcs_01M5KGGR23B7H9PN2F1T8KP8KJ","modified_at":"2023-11-08T04:09:41.005431Z","published_at":"2022-07-26T06:15:00Z","references":["https://osv.dev/vulnerability/PYSEC-2022-243","https://jvn.jp/en/jp/JVN30454777/","https://github.com/stchris/untangle","https://github.com/stchris/untangle/releases/tag/1.2.1","https://github.com/advisories/GHSA-7xr3-6ggc-wc9p"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2022-243","url":"https://osv.dev/vulnerability/PYSEC-2022-243"}],"summary":"untangle is a python library to convert XML data to python objects. untangle versions 1.2.0 and earlier improperly restricts recursive entity references in DTDs. By exploiting this vulnerability, a re"}