{"action":"Upgrade ansible-runner to 2.1.0 or later.","affected":[{"fixed":"2.1.0","introduced":"0"}],"component":"ansible-runner","cve_ids":["CVE-2021-4041"],"ecosystem":"PyPI","epss":0.00332,"exploited":false,"fixed_versions":["2.1.0"],"ghsa_id":"GHSA-6j58-grhv-2769","id":"tcs_01M5KGGSNKYH3B3B1GGDVG0KYE","modified_at":"2023-11-08T04:06:47.591366Z","published_at":"2022-08-24T16:15:00Z","references":["https://osv.dev/vulnerability/PYSEC-2022-253","https://bugzilla.redhat.com/show_bug.cgi?id=2028074","https://access.redhat.com/security/cve/CVE-2021-4041","https://github.com/ansible/ansible-runner/commit/3533f265f4349a3f2a0283158cd01b59a6bbc7bd","https://github.com/advisories/GHSA-6j58-grhv-2769"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2022-253","url":"https://osv.dev/vulnerability/PYSEC-2022-253"}],"summary":"A flaw was found in ansible-runner. An improper escaping of the shell command, while calling the ansible_runner.interface.run_command, can lead to parameters getting executed as host's shell command."}