{"action":"Upgrade deluge to 2.1.0 or later.","affected":[{"fixed":"2.1.0","introduced":"0"}],"component":"deluge","cve_ids":["CVE-2021-3427"],"ecosystem":"PyPI","epss":0.00959,"exploited":false,"fixed_versions":["2.1.0"],"ghsa_id":"GHSA-5c8p-qhch-qhx6","id":"tcs_01M5KGGTG88V1YVDWH5QCZRWBM","modified_at":"2023-11-08T04:06:07.630449Z","published_at":"2022-08-26T16:15:00Z","references":["https://osv.dev/vulnerability/PYSEC-2022-256","https://groups.google.com/g/deluge-dev/c/e5zh7wT0rEg","https://dev.deluge-torrent.org/ticket/3459","https://github.com/advisories/GHSA-5c8p-qhch-qhx6"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2022-256","url":"https://osv.dev/vulnerability/PYSEC-2022-256"}],"summary":"The Deluge Web-UI is vulnerable to XSS through a crafted torrent file. The the data from torrent files is not properly sanitised as it's interpreted directly as HTML. Someone who supplies the user wit"}