{"action":"Upgrade indy-node to 1.12.5rc1 or later.","affected":[{"fixed":"1.12.5rc1","introduced":"0"}],"component":"indy-node","cve_ids":["CVE-2022-31020"],"ecosystem":"PyPI","epss":0.02259,"exploited":false,"fixed_versions":["1.12.5rc1"],"ghsa_id":"GHSA-r6v9-p59m-gj2p","id":"tcs_01M5KGGW4BDDVE7SNM5BKZQF19","modified_at":"2023-11-08T04:09:22.844035Z","published_at":"2022-09-06T17:15:00Z","references":["https://osv.dev/vulnerability/PYSEC-2022-265","https://github.com/hyperledger/indy-node/commit/fe507474f77084faef4539101e2bbb4d508a97f5","https://github.com/hyperledger/indy-node/security/advisories/GHSA-r6v9-p59m-gj2p","https://github.com/hyperledger/indy-node/releases/tag/v1.12.5"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2022-265","url":"https://osv.dev/vulnerability/PYSEC-2022-265"}],"summary":"Indy Node is the server portion of a distributed ledger purpose-built for decentralized identity. In versions 1.12.4 and prior, the `pool-upgrade` request handler in Indy-Node allows an improperly aut"}