{"action":"Upgrade apache-airflow to 2.2.4 or later.","affected":[{"fixed":"2.2.4","introduced":"0"}],"component":"apache-airflow","cve_ids":["CVE-2022-24288"],"ecosystem":"PyPI","epss":0.7788,"exploited":false,"fixed_versions":["2.2.4"],"ghsa_id":"GHSA-3v7g-4pg3-7r6j","id":"tcs_01M5KGH2Y3BJZQBVVYNJ42M772","modified_at":"2023-12-06T01:02:03.729242Z","published_at":"2022-02-25T09:15:00Z","references":["https://osv.dev/vulnerability/PYSEC-2022-30","https://lists.apache.org/thread/dbw5ozcmr0h0lhs0yjph7xdc64oht23t","https://github.com/advisories/GHSA-3v7g-4pg3-7r6j"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2022-30","url":"https://osv.dev/vulnerability/PYSEC-2022-30"}],"summary":"In Apache Airflow, prior to version 2.2.4, some example DAGs did not properly sanitize user-provided params, making them susceptible to OS Command Injection from the web UI."}