{"action":"Upgrade apache-airflow to 2.4.2 or later.","affected":[{"fixed":"2.4.2","introduced":"0"}],"component":"apache-airflow","cve_ids":["CVE-2022-43982"],"ecosystem":"PyPI","epss":0.01759,"exploited":false,"fixed_versions":["2.4.2"],"ghsa_id":"GHSA-h63r-9xxf-f2c7","id":"tcs_01M5KGH6EMTTTDQSHH151YFBMX","modified_at":"2026-06-10T17:00:19.351007619Z","published_at":"2022-11-02T12:15:00Z","references":["https://osv.dev/vulnerability/PYSEC-2022-42970","https://lists.apache.org/thread/vqnvdrfsw9z7v7c46qh3psjgr7wy959l","https://github.com/apache/airflow/pull/27143","https://github.com/advisories/GHSA-h63r-9xxf-f2c7"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2022-42970","url":"https://osv.dev/vulnerability/PYSEC-2022-42970"}],"summary":"In Apache Airflow versions prior to 2.4.2, the \"Trigger DAG with config\" screen was susceptible to XSS attacks via the `origin` query argument."}