{"action":"Upgrade pyspark to 3.2.2 or later.","affected":[{"fixed":"3.2.2","introduced":"0"}],"component":"pyspark","cve_ids":["CVE-2022-31777"],"ecosystem":"PyPI","epss":0.0164,"exploited":false,"fixed_versions":["3.2.2"],"ghsa_id":"GHSA-43xg-8wmj-cw8h","id":"tcs_01M5KGH7CJ8G6HYHPR00AMGJ52","modified_at":"2026-06-10T17:01:37.003052396Z","published_at":"2022-11-01T16:15:00Z","references":["https://osv.dev/vulnerability/PYSEC-2022-42976","https://lists.apache.org/thread/60mgbswq2lsmrxykfxpqq13ztkm2ht6q","https://github.com/advisories/GHSA-43xg-8wmj-cw8h"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2022-42976","url":"https://osv.dev/vulnerability/PYSEC-2022-42976"}],"summary":"A stored cross-site scripting (XSS) vulnerability in Apache Spark 3.2.1 and earlier, and 3.3.0, allows remote attackers to execute arbitrary JavaScript in the web browser of a user, by including a mal"}