{"action":"Upgrade apache-airflow to 2.4.0 or later.","affected":[{"fixed":"2.4.0","introduced":"0"}],"component":"apache-airflow","cve_ids":["CVE-2022-40127"],"ecosystem":"PyPI","epss":0.85653,"exploited":false,"fixed_versions":["2.4.0"],"ghsa_id":"GHSA-6pw3-8h9w-32gc","id":"tcs_01M5KGH8N0CXSA1685Y73MMVC6","modified_at":"2026-06-10T17:00:19.937965152Z","published_at":"2022-11-14T10:15:00Z","references":["https://osv.dev/vulnerability/PYSEC-2022-42982","https://github.com/apache/airflow/pull/25960","https://lists.apache.org/thread/cf132hgm6jvzvsbpsozl3plf1r4cwysy","http://www.openwall.com/lists/oss-security/2022/11/14/2","https://github.com/advisories/GHSA-6pw3-8h9w-32gc"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2022-42982","url":"https://osv.dev/vulnerability/PYSEC-2022-42982"}],"summary":"A vulnerability in Example Dags of Apache Airflow allows an attacker with UI access who can trigger DAGs, to execute arbitrary commands via manually provided run_id parameter. This issue affects Apach"}