{"action":"Upgrade guarddog to 0.1.8 or later.","affected":[{"fixed":"0.1.8","introduced":"0"}],"component":"guarddog","cve_ids":["CVE-2022-23530"],"ecosystem":"PyPI","epss":0.00751,"exploited":false,"fixed_versions":["0.1.8"],"ghsa_id":"GHSA-78m5-jpmf-ch7v","id":"tcs_01M5KGHADJ72N9XGWHBYJMDH7Y","modified_at":"2023-11-08T04:08:21.047020Z","published_at":"2022-12-16T23:15:00Z","references":["https://osv.dev/vulnerability/PYSEC-2022-42993","https://github.com/DataDog/guarddog/blob/a1d064ceb09d39bb28deb6972bc0a278756ea91f/guarddog/scanners/package_scanner.py#L153..158","https://github.com/DataDog/guarddog/security/advisories/GHSA-78m5-jpmf-ch7v","https://github.com/DataDog/guarddog/commit/37c7d0767ba28f4df46117d478f97652594c491c"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2022-42993","url":"https://osv.dev/vulnerability/PYSEC-2022-42993"}],"summary":"GuardDog is a CLI tool to identify malicious PyPI packages. Versions prior to v0.1.8 are vulnerable to arbitrary file write when scanning a specially-crafted remote PyPI package. Extracting files usin"}