{"action":"Upgrade guarddog to 0.1.5 or later.","affected":[{"fixed":"0.1.5","introduced":"0"}],"component":"guarddog","cve_ids":["CVE-2022-23531"],"ecosystem":"PyPI","epss":0.00734,"exploited":false,"fixed_versions":["0.1.5"],"ghsa_id":"GHSA-rp2v-v467-q9vq","id":"tcs_01M5KGHAJ167JPPDNC72JTHKJF","modified_at":"2026-02-22T22:48:54.447356Z","published_at":"2022-12-17T00:15:00Z","references":["https://osv.dev/vulnerability/PYSEC-2022-42994","https://github.com/DataDog/guarddog/releases/tag/v0.1.5","https://github.com/DataDog/guarddog/security/advisories/GHSA-rp2v-v467-q9vq","https://github.com/DataDog/guarddog/pull/89/commits/a56aff58264cb6b7855d71b00dc10c39a5dbd306"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2022-42994","url":"https://osv.dev/vulnerability/PYSEC-2022-42994"}],"summary":"GuardDog is a CLI tool to identify malicious PyPI packages. Versions prior to 0.1.5 are vulnerable to Relative Path Traversal when scanning a specially-crafted local PyPI package. Running GuardDog aga"}