{"action":"Upgrade srp to 1.0.17 or later.","affected":[{"fixed":"1.0.17","introduced":"0"}],"component":"srp","cve_ids":["CVE-2021-4286"],"ecosystem":"PyPI","epss":0.00765,"exploited":false,"fixed_versions":["1.0.17"],"ghsa_id":"GHSA-xmc3-9m9j-w9x4","id":"tcs_01M5KGHE2BM5MMNSGEEQYW582J","modified_at":"2026-06-10T17:02:42.260110027Z","published_at":"2022-12-27T11:15:00Z","references":["https://osv.dev/vulnerability/PYSEC-2022-43014","https://vuldb.com/?id.216875","https://vuldb.com/?ctiid.216875","https://github.com/cocagne/pysrp/commit/dba52642f5e95d3da7af1780561213ee6053195f","https://github.com/cocagne/pysrp/releases/tag/1.0.17","https://github.com/cocagne/pysrp/pull/43","https://github.com/advisories/GHSA-xmc3-9m9j-w9x4"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2022-43014","url":"https://osv.dev/vulnerability/PYSEC-2022-43014"}],"summary":"A vulnerability, which was classified as problematic, has been found in cocagne pysrp up to 1.0.16. This issue affects the function calculate_x of the file srp/_ctsrp.py. The manipulation leads to inf"}