{"action":"Upgrade torch to 1.13.1 or later.","affected":[{"fixed":"1.13.1","introduced":"0"}],"component":"torch","cve_ids":["CVE-2022-45907"],"ecosystem":"PyPI","epss":0.01332,"exploited":false,"fixed_versions":["1.13.1"],"ghsa_id":"GHSA-47fc-vmwq-366v","id":"tcs_01M5KGHE730P4XZRS1TBH8RAW4","modified_at":"2026-06-10T17:51:27.754911892Z","published_at":"2022-11-26T02:15:00Z","references":["https://osv.dev/vulnerability/PYSEC-2022-43015","https://github.com/pytorch/pytorch/commit/767f6aa49fe20a2766b9843d01e3b7f7793df6a3","https://github.com/pytorch/pytorch/issues/88868","https://github.com/advisories/GHSA-47fc-vmwq-366v"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2022-43015","url":"https://osv.dev/vulnerability/PYSEC-2022-43015"}],"summary":"In PyTorch before trunk/89695, torch.jit.annotations.parse_type_line can cause arbitrary code execution because eval is used unsafely."}