{"action":"Upgrade wheel to 0.38.1 or later.","affected":[{"fixed":"0.38.1","introduced":"0"}],"component":"wheel","cve_ids":["CVE-2022-40898"],"ecosystem":"PyPI","epss":0.02837,"exploited":false,"fixed_versions":["0.38.1"],"ghsa_id":"GHSA-qwmp-2cf2-g9g6","id":"tcs_01M5KGHEFZ6PG0DN57D24ARKD7","modified_at":"2026-06-10T17:02:50.204495025Z","published_at":"2022-12-23T00:15:00Z","references":["https://osv.dev/vulnerability/PYSEC-2022-43017","https://pypi.org/project/wheel/","https://github.com/pypa/wheel/blob/main/src/wheel/wheelfile.py#L18","https://pyup.io/posts/pyup-discovers-redos-vulnerabilities-in-top-python-packages/","https://github.com/advisories/GHSA-qwmp-2cf2-g9g6"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2022-43017","url":"https://osv.dev/vulnerability/PYSEC-2022-43017"}],"summary":"An issue discovered in Python Packaging Authority (PyPA) Wheel 0.37.1 and earlier allows remote attackers to cause a denial of service via attacker controlled input to wheel cli."}