{"action":"Upgrade py-cord to 2.0.1 or later.","affected":[{"fixed":"2.0.1","introduced":"2.0.0"}],"component":"py-cord","cve_ids":["CVE-2022-36024"],"ecosystem":"PyPI","epss":0.00797,"exploited":false,"fixed_versions":["2.0.1"],"ghsa_id":"GHSA-qmhj-m29v-gvmr","id":"tcs_01M5KGHS39E3SNPAQ4A8FRADP0","modified_at":"2024-11-25T22:42:10.994127Z","published_at":"2022-08-18T15:15:00Z","references":["https://osv.dev/vulnerability/PYSEC-2022-43146","https://github.com/Pycord-Development/pycord/security/advisories/GHSA-qmhj-m29v-gvmr","https://github.com/Pycord-Development/pycord/pull/1568"],"severity":{"label":"medium","score":6.5},"sources":[{"source":"osv","source_id":"PYSEC-2022-43146","url":"https://osv.dev/vulnerability/PYSEC-2022-43146"}],"summary":"py-cord is a an API wrapper for Discord written in Python. Bots creating using py-cord version 2.0.0 are vulnerable to remote shutdown if they are added to the server with the `application.commands` s"}