{"action":"Upgrade obsidian-dataview to 0.4.13 or later.","affected":[{"fixed":"0.4.13","introduced":"0"}],"component":"obsidian-dataview","cve_ids":["CVE-2021-42057"],"ecosystem":"npm","epss":0.01245,"exploited":false,"fixed_versions":["0.4.13"],"ghsa_id":"GHSA-xfg5-vrmc-24wc","id":"tcs_01M5KGHT5V6EQ0RDFH6N70C78B","modified_at":"2023-11-08T04:07:04.853275Z","published_at":"2022-05-24T19:19:42Z","references":["https://osv.dev/vulnerability/GHSA-xfg5-vrmc-24wc","https://nvd.nist.gov/vuln/detail/CVE-2021-42057","https://github.com/blacksmithgu/obsidian-dataview/issues/615","https://github.com/blacksmithgu/obsidian-dataview"],"severity":{"label":"high","score":7.8},"sources":[{"source":"osv","source_id":"GHSA-xfg5-vrmc-24wc","url":"https://osv.dev/vulnerability/GHSA-xfg5-vrmc-24wc"}],"summary":"Obsidian Dataview vulnerable to code injection due to unsafe eval"}