{"action":"Upgrade deap to 1.0.1 or later.","affected":[{"fixed":"1.0.1","introduced":"0"}],"component":"deap","cve_ids":["CVE-2018-3749"],"ecosystem":"npm","epss":0.01428,"exploited":false,"fixed_versions":["1.0.1"],"ghsa_id":"GHSA-xg47-r67p-vhv5","id":"tcs_01M5KGHX245XMYQS5QRXX0HMXW","modified_at":"2023-11-08T04:00:18.781426Z","published_at":"2022-05-14T03:05:46Z","references":["https://osv.dev/vulnerability/GHSA-xg47-r67p-vhv5","https://nvd.nist.gov/vuln/detail/CVE-2018-3749","https://github.com/selfcontained/deap/commit/ed27b7e890bdd616e1ee931ea1c64228e2b52a71","https://hackerone.com/reports/310446","https://github.com/selfcontained/deap"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"GHSA-xg47-r67p-vhv5","url":"https://osv.dev/vulnerability/GHSA-xg47-r67p-vhv5"}],"summary":"Improper Input Validation in Deap"}