{"action":"Upgrade npm-user-validate to 1.0.1 or later.","affected":[{"fixed":"1.0.1","introduced":"0"}],"component":"npm-user-validate","cve_ids":["CVE-2020-7754"],"ecosystem":"npm","epss":0.03481,"exploited":false,"fixed_versions":["1.0.1"],"ghsa_id":"GHSA-xgh6-85xh-479p","id":"tcs_01M5KGHZBYS7NRXBZ9ADV6WP4K","modified_at":"2026-07-08T06:49:44.248240618Z","published_at":"2020-10-16T18:56:26Z","references":["https://osv.dev/vulnerability/GHSA-xgh6-85xh-479p","https://github.com/npm/npm-user-validate/security/advisories/GHSA-xgh6-85xh-479p"],"severity":{"label":"low"},"sources":[{"source":"osv","source_id":"GHSA-xgh6-85xh-479p","url":"https://osv.dev/vulnerability/GHSA-xgh6-85xh-479p"}],"summary":"Regular Expression Denial of Service in npm-user-validate"}